Go Back   The Ford Barn > General Discussion > Model A (1928-31)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 05-15-2020, 01:11 PM   #1
youngd7
Junior Member
 
youngd7's Avatar
 
Join Date: May 2010
Posts: 26
Default model A with a stromberg 97 stalls at highway speeds

Hi guys, Struggling with a problem on my model A. I have a new Stromberg 97 on my model A ford. When I drive at 50 mph or above it stalls like it's running out of gas. If I pull to the shoulder , reduce speed it's like the fuel pump catches up and I can continue driving. This problem is very consistent. I have set timing, changed points, condenser, coil, cleaned and checked grounds. For fuel I have checked float level, cleaned the inlet valve, checked fuel pressure, rerouted fuel line to be sure of no vapor lock. Originally I had a Carter 6 volt vane pump and that would vapor lock when the car sat too long otherwise car ran good. Changed it to a Carter electric diaphragm pump and that worked good for a while until this problem popped up. Any ideas?? Also wondering what fuel pumps you are using on down draft set ups?
youngd7 is offline   Reply With Quote
Old 05-15-2020, 01:28 PM   #2
CarlG
Senior Member
 
CarlG's Avatar
 
Join Date: Nov 2010
Location: Anchorage, Alaska
Posts: 8,621
Default Re: model A with a stromberg 97 stalls at highway speeds

When my Carter fuel pump gave out, I ordered a new one. In the meantime while waiting for the new one to arrive, I went to O'Riley's and just bought whatever they had on the shelf. Installed that one and 2 years later (about 4,000 miles) it's still pumping good. New Carter pump is still on the shelf.
__________________
Alaskan A's
Antique Auto Mushers of Alaska
Model A Ford Club of America
Model A Restorers Club
Antique Automobile Club of America
Mullins Owner's Club
CarlG is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 05-15-2020, 01:44 PM   #3
MikeK
Senior Member
 
MikeK's Avatar
 
Join Date: May 2010
Location: Windy City
Posts: 2,883
Default Re: model A with a stromberg 97 stalls at highway speeds

Check for a restricted fuel flow FROM tank TO pump. I assume your pump is mounted well below the tank, at frame level? With feed line disconnected at the pump measure the fuel free flow through everything to the pump. It should whizz continuously unrestricted like a racehorse into a catch can. If you have any filter or sediment bowl that will initiate vaporization with increased flow upstream of the pump that could be the problem. Also check that your gas cap is properly vented.
__________________
Mechanical engineering 101: If you put an adjustment knob, screw, bolt, or tolerance specs on something, some people will immediately fiddle with it. If you mark it DO NOT TOUCH everyone will mess with it.
MikeK is offline   Reply With Quote
Old 05-15-2020, 02:32 PM   #4
Jack Shaft
Senior Member
 
Join Date: Dec 2019
Posts: 771
Default Re: model A with a stromberg 97 stalls at highway speeds

If the issue occurs above half throttle check and clean the power valve.the power valve enrichens once you exceed acceleratop pump stroke
Jack Shaft is offline   Reply With Quote
Old 05-15-2020, 03:12 PM   #5
midgetracer
Senior Member
 
midgetracer's Avatar
 
Join Date: May 2010
Location: Bismarck ND
Posts: 967
Default Re: model A with a stromberg 97 stalls at highway speeds

I had the same problem, and it was the diaphragm pump. I went back to the vane pump and my problems went away. Both were Carter pumps sold by NAPA.
midgetracer is offline   Reply With Quote
Old 05-15-2020, 08:11 PM   #6
youngd7
Junior Member
 
youngd7's Avatar
 
Join Date: May 2010
Posts: 26
Default Re: model A with a stromberg 97 stalls at highway speeds

Sponsored Links (Register now to hide all advertisements)
MikeK Fuel pump is mounted on the inside of the frame rail. I did check for flow after the pump and it was very good. Gas cap vent is working. I do have a stock glass sediment bowl with a filter in it. How would this create vapor lock?
youngd7 is offline   Reply With Quote
Old 05-15-2020, 08:17 PM   #7
youngd7
Junior Member
 
youngd7's Avatar
 
Join Date: May 2010
Posts: 26
Default Re: model A with a stromberg 97 stalls at highway speeds

Midgetracer I think that is my next step, to replace the diaphragm pump with the vane pump and see if the problem goes away. If I remember correctly my Carter vane pump had a pretty high flow rate. I called Carter when I figured out the vane pump was vapor locking and they told me to run a return line into the tank. I told them it was a model A and he told me to tap into the gas cap with the return line. What??!!
youngd7 is offline   Reply With Quote
Old 05-16-2020, 10:19 AM   #8
MikeK
Senior Member
 
MikeK's Avatar
 
Join Date: May 2010
Location: Windy City
Posts: 2,883
Default Re: model A with a stromberg 97 stalls at highway speeds

Quote:
Originally Posted by youngd7 View Post
MikeK Fuel pump is mounted on the inside of the frame rail. I did check for flow after the pump and it was very good. Gas cap vent is working. I do have a stock glass sediment bowl with a filter in it. How would this create vapor lock?
If your pump feeds fuel at a faster rate than gravity flow to it then a slight negative pressure is produced in the tank feed line. That is why I said check for full flow at the pump inlet, not it's output.

While driving at speed there is considerable under hood heat, both in the air through the radiator and radiant, from the exhaust to the fuel line and sediment bowl. Modern gas contains a great deal of light fractions and is not designed for systems without submerged pressure pumps and all highly (25-75 psi) pressurized feed lines.

With modern gas any slight negativity in the tank feed, through elbows, valves, sediment bowls, filters, rough spots, etc. provide nucleation points for vaporization in the line when that line is warmer than the fuel itself.

Of course, your problem may be something completely different as suggested above, but I just wanted to make sure as many bases as possible were covered in your persuit for a fix! When you do find the fix, please post! Inquiring minds want to know!
__________________
Mechanical engineering 101: If you put an adjustment knob, screw, bolt, or tolerance specs on something, some people will immediately fiddle with it. If you mark it DO NOT TOUCH everyone will mess with it.
MikeK is offline   Reply With Quote
Old 05-16-2020, 08:22 PM   #9
youngd7
Junior Member
 
youngd7's Avatar
 
Join Date: May 2010
Posts: 26
Default Re: model A with a stromberg 97 stalls at highway speeds

MikeK
Thanks for the explanation. I have read this about modern fuels before, your explanation makes sense to me. I will let everyone know what I find.
youngd7 is offline   Reply With Quote
Old 05-17-2020, 08:34 AM   #10
1929
Senior Member
 
Join Date: Jan 2015
Location: New York
Posts: 903
Default Re: model A with a stromberg 97 stalls at highway speeds

Had issues too,I removed my pump from the 97, one less thing to break down, car will still do up to 60mph no problem.
1929 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 01:21 AM.