Go Back   The Ford Barn > General Discussion > Early V8 (1932-53)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 04-02-2021, 09:25 PM   #1
Smitty
Senior Member
 
Smitty's Avatar
 
Join Date: May 2010
Location: Boston North Shore
Posts: 676
Default 1950 Ford Wiper

The wiper mechanism in my 50 works fine without the wiper arms but when I install the arms and blades it does not seem to have enough power to move the blades back and forth. I took the wiper motor apart and cleaned and lubricated the inside and was working great when testing so the motor is working.
Any thoughts?
Thanks, Smitty
Smitty is offline   Reply With Quote
Old 04-03-2021, 05:25 AM   #2
leon bee
Senior Member
 
Join Date: May 2017
Location: Arkansas
Posts: 535
Default Re: 1950 Ford Wiper

I made a vast improvement in my 50 wipers by cleaning out the little spigot on the manifold where hose attaches.
leon bee is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 04-03-2021, 09:04 PM   #3
Smitty
Senior Member
 
Smitty's Avatar
 
Join Date: May 2010
Location: Boston North Shore
Posts: 676
Default Re: 1950 Ford Wiper

Had not thought of that, I will give it a try. Thanks, Steve
Smitty is offline   Reply With Quote
Old 04-04-2021, 05:41 AM   #4
51woodie
Senior Member
 
51woodie's Avatar
 
Join Date: Apr 2018
Location: Chelmsford, ON Canada
Posts: 386
Default Re: 1950 Ford Wiper

Had that problem with my '46 Coupe. I changed the vacuum motor, and not much improvement. More investigation found that the shaft that comes up through the cowl, was partially seized in the piece that it goes through. I also figured out that the previous owner installed not stock (see pic) wiper blades and arms. The spring tension on the arms was too high, and the wiper blades were twice as heavy as the stock type. Freed up the shaft installed correct arms/blades and all is good. I use Rain Away on the glass, which also helps to disperse the rain. Take care to get it on the glass only.
Attached Images
File Type: jpg Wiper Closeup.jpg (76.6 KB, 6 views)
51woodie is offline   Reply With Quote
Old 04-04-2021, 07:23 AM   #5
Smitty
Senior Member
 
Smitty's Avatar
 
Join Date: May 2010
Location: Boston North Shore
Posts: 676
Default Re: 1950 Ford Wiper

Sponsored Links (Register now to hide all advertisements)
My arms are repop and additionally shortened, I question whether the springs may be too stiff. Mechanisms have been all apart, cleaned and lubed including the motor. Everything works fine until I attach the blades.
Smitty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 01:56 AM.