Go Back   The Ford Barn > General Discussion > Model A (1928-31)

Sponsored Links (Register now to hide all advertisements)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-04-2020, 01:47 PM   #1
saxman657
Member
 
Join Date: Apr 2019
Location: Orange County, CA
Posts: 32
Default Radiator Overheating

I'm sure this query will be somewhat repetitive from others, but here goes. First background: I started the TLC of my father-in-law's Model A last year. First time out after changing out filters in bowl and filling up a dry gas tank I spewed a huge amount of rusty water. Got her home and shoved a hose down the radiator and flushed a lot of rust out and ran until water was clean. Then flushed with a Blue Devil product. Filled up with distilled water and added water wetter - no antifreeze since I'm in SoCal. Car ran great at speeds up to 53-55mph. A couple of months ago I drained the radiator and decided to add a 50/50 mix of old fashioned Prestone. Started to overheat at highway speeds after running for maybe 15-20 min. Hmmm. So I flushed with Thermocure, letting sit for about a week. Then flushed and back-flushed with garden hose. Still overheated. Added a Gano filter and ran for several weeks. Took her up into summer desert hills and started the overheating again. Got her home and pulled the filter to find a good amount of what looked like mineral deposits, but no rust! Cleaned it out and have noticed it is still overheating.

Next steps, and I'm looking for help here. I plan to drain and clean the Gano filter, and then run the white vinegar for a week. Should I use 2 gal to fill radiator and then top off with water if I need to? Also, I read where it is recommended to follow with a flush of baking soda and water to neutralize the effect of vinegar. How much baking soda do I use? A box in several gallons of water?

If all goes well, I plan to try Royal Purple Ice and bottled filtered drinking water. Has anyone used this product before. Royal Purple says I can use with antifreeze too, but I don't see the need considering the environment here in SoCal.
saxman657 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 06:44 AM.