Go Back   The Ford Barn > General Discussion > Early V8 (1932-53)

Sponsored Links (Register now to hide all advertisements)

Reply
 
Thread Tools Display Modes
Old 07-15-2020, 05:13 PM   #1
dgmgohl
Member
 
Join Date: Aug 2018
Posts: 42
Default Someday this engine will run right.

Hi, I just put in an electronic ignition from Pertronix. After knocking my head against the wall trying to figure out why this newly rebuilt engine and carb wouldn't run. Tossed the points and condensor for electronic ignition. Started right ran good. Drove it for about an hour, but still had to time it cause it felt off a little. Timed it, tightened the distributor down, and ran great for about a minute and a half then stopped cold. No spark. Is it possible I burned the Pertronix unit for having the key switch on to long? I also had bought a Pertronix "flame thrower" coil. And it was major hot. Put a different coil in, and still no spark. Any suggestions?
dgmgohl is offline   Reply With Quote
Old 07-15-2020, 05:48 PM   #2
Kube
Senior Member
 
Kube's Avatar
 
Join Date: May 2010
Location: Wisconsin, USA
Posts: 6,392
Default Re: Someday this engine will run right.

Quote:
Originally Posted by dgmgohl View Post
Hi, I just put in an electronic ignition from Pertronix. After knocking my head against the wall trying to figure out why this newly rebuilt engine and carb wouldn't run. Tossed the points and condensor for electronic ignition. Started right ran good. Drove it for about an hour, but still had to time it cause it felt off a little. Timed it, tightened the distributor down, and ran great for about a minute and a half then stopped cold. No spark. Is it possible I burned the Pertronix unit for having the key switch on to long? I also had bought a Pertronix "flame thrower" coil. And it was major hot. Put a different coil in, and still no spark. Any suggestions?
I think in the long run, you'd be better off having the authentic distributor rebuilt by one of the true professionals. Ya know, do it once, do it right.
I'd also suggest you have the authentic coil rebuilt at the same time and acquire a condenser from Hunt's Magnetos.
The original parts run VERY well IF they are set up correctly.
__________________
"I can explain it for you. However, I can't understand it for you".
Kube is offline   Reply With Quote
Sponsored Links (Register now to hide all advertisements)
Old 07-15-2020, 06:54 PM   #3
tubman
Senior Member
 
tubman's Avatar
 
Join Date: Dec 2013
Location: Minnesota, Florida Keys
Posts: 6,777
Default Re: Someday this engine will run right.

I went back and checked and it seems you are inquiring about a '53 Mercury engine in your 1952 Ford, correct. May I ask, are you running 6 volts or has it been converted to 12 volts?

6 volt Pertronics units have proven to be problematic.

Last edited by tubman; 07-15-2020 at 07:02 PM.
tubman is offline   Reply With Quote
Old 07-15-2020, 06:55 PM   #4
Talkwrench
Senior Member
 
Talkwrench's Avatar
 
Join Date: Aug 2012
Location: Perth, Western Australia
Posts: 2,546
Default Re: Someday this engine will run right.

There's nothing wrong with either electronic or the original . Its most important to understand that you dont put in parts on a dizzy thats flogged and expect it to work well especially electronic units. Parts must be matched with the correct Ohms coil, and the unit must get the correct voltage etc. Ive had electronic units in all my cars and NEVER had a failure. Yes it sounds like you have an early Pertronix and if you leave the ign on it fu*ks them. You need to talk to Jim , Charlie or Mike is doing dizzy's now?
__________________
"Came too close to dying to stop living now!"
Talkwrench is offline   Reply With Quote
Old 07-15-2020, 07:58 PM   #5
dgmgohl
Member
 
Join Date: Aug 2018
Posts: 42
Default Re: Someday this engine will run right.

I'm running 6 volt
dgmgohl is offline   Reply With Quote
Old 07-15-2020, 08:15 PM   #6
tubman
Senior Member
 
tubman's Avatar
 
Join Date: Dec 2013
Location: Minnesota, Florida Keys
Posts: 6,777
Default Re: Someday this engine will run right.

Sponsored Links (Register now to hide all advertisements)
So lets get down to basics. Since Pertronix doesn't make an 8BA type distributor (to my knowledge) it seems that you must have installed a kit into the stock distributor. Are you running stock carburetion? If not, the "Load-a-matic distributor is a very poor choice. If you installed the Pertronix unit in your distributor, it won't help if the original distributor is worn out or defective. Plus, as I have said before, 6 volt Pertronix units are problematic, especially if you are running a stock generator, which produces very "dirty" electrical output. At this point, I would suggest that you have two choices; get a known good stock points distributor, or go to an upgraded aftermarket unit. Unfortunately, the only remaining supplier of upgraded SBC conversion distributors "Charlie ny" has sold out the 50 he finished last week and it will probably take a while for him to gear up again.

I have a "Load-a-matic" that I pulled out of a good running engine a couple of years ago that I could send you to try (depending where you are located). Let me know if I'm off-base on anything I've surmised.
tubman is offline   Reply With Quote
Old 07-16-2020, 06:07 AM   #7
dgmgohl
Member
 
Join Date: Aug 2018
Posts: 42
Default Re: Someday this engine will run right.

Everything is still stock. I run a teapot carb recently rebuilt by scalia here on ford barn. The distributor is original and matches whats suppose to be in the motor. I'm in Minnesota, west metro area. I'm not experienced enough to replace a distributor, but the funny thing is the motor ran perfect the night before it stopped. My wife and I went for a cruise for over an hour with no mishaps. Its only after I re-set the timing. My fear is that I left the switch on and fried the unit.
dgmgohl is offline   Reply With Quote
Old 07-16-2020, 06:11 AM   #8
dgmgohl
Member
 
Join Date: Aug 2018
Posts: 42
Default Re: Someday this engine will run right.

What's the difference between a "load a matic" distributor and a regular unit?
dgmgohl is offline   Reply With Quote
Old 07-16-2020, 06:58 AM   #9
oldskool
Senior Member
 
oldskool's Avatar
 
Join Date: May 2010
Location: shirley ny
Posts: 913
Default Re: Someday this engine will run right.

i heard you can't run solid core ign wires with pertronix is that correct?
oldskool is offline   Reply With Quote
Old 07-16-2020, 08:13 AM   #10
tubman
Senior Member
 
tubman's Avatar
 
Join Date: Dec 2013
Location: Minnesota, Florida Keys
Posts: 6,777
Default Re: Someday this engine will run right.

A "Load-a-matic" uses a combination of venturi and ported vacuum to run the advance mechanism. They require a carburetor with a port about half way up the back side of the carburetor with a vacuum line going to the distributor. This system was only used on Ford products between 1949 an 1956 and while it works well when everything is in good shape on a stock engine, it operates differently from all other ignition advance systems. A "regular" distributor can have mechanical (centrifugal) advance only or a combination of mechanical and vacuum advance. A mechanical advance works by using weights inside the distributor; as engine speed increases, the weights move out by centrifugal force which moves the point plate inside the distributor, advancing the spark (making it occur earlier in the combustion process). It should be noted that the Ford "Load-a-matic" system does not use a mechanical advance mechanism and depends solely on it's special vacuum advance mechanism. A "regular" distributor can also have a vacuum advance mechanism that works in concert with the mechanical advance. Basically, under conditions of high engine load manifold vacuum drops, the lower vacuum is detected by a diaphragm in the distributor and causes the spark to advance even more.

Clear as mud? In summary, a Ford "Load-a-matic" system functions differently from all other systems and requires a special carburetor designed specifically for use with it. lt should be noted that since the Ford system does not have any mechanical advance, the vacuum system has to be functioning or there will be problems.

As I said in an earlier post, the stock generator produces "dirty" power with voltage spikes that can damage am electronic device such as a Pertronix. As mentioned above, solid core plug wires can also cause problems with a Pertronix. I believe they specify spiral wound wires for their installations. Generally Pertronix systems do not do well on 6 volt systems.

Since you said that the car ran well for an hour with the Pertronix, I believe that we can assume that the distributor is in decent shape and the vacuum advance system is functioning properly. I believe that the Pertronix unit is "fried", either because you left the key on or (more likely) because of the "dirty" power produced by these old cars. In my opinion, the proper route for you to take at this time would be to get the proper points and condenser from a reliable source (such as NAPA) and install them according to the factory specifications. If you have a multi-meter, it would also be a good idea to use it to do a preliminary check on your coil. Set the meter to the proper "Ohms" scale and check the resistance of the coil. The primary circuit should be relatively low (less than 10 ohms), while the secondary should be high (over 10,000). Make sure the timing is set to the dot on the crankshafy pulley (with the vacuum line disconnected) and you should be good to go.

I have a similar setup as you (a '51 Mercury" engine in a '51 Ford). I have had the car a long time, and for the first 35 years I owned it, I ran a stock engine with a "Load-a-matic" and the car performed flawlessly. A couple of years ago, the original engine was starting to get a little tired, so I installed the Mercury, along with some finned aluminum heads, updated carburetion, and a Mallory dual point mechanical only distributor. The car still runs well, starts at a touch of the key, and the increased power is very noticeable.

Good luck on your quest.
tubman is offline   Reply With Quote
Old 07-16-2020, 04:00 PM   #11
drolston
Senior Member
 
drolston's Avatar
 
Join Date: Jun 2014
Location: Williamsburg, VA
Posts: 1,099
Default Re: Someday this engine will run right.

Quote:
Originally Posted by oldskool View Post
i heard you can't run solid core ign wires with pertronix is that correct?
Pertronix recommends the coil wound center conductor, and against solid core for the coil and spark plug wires..
drolston is offline   Reply With Quote
Old 07-16-2020, 04:41 PM   #12
Ronnieroadster
Senior Member
 
Ronnieroadster's Avatar
 
Join Date: Dec 2010
Location: East Coast in CT
Posts: 853
Default Re: Someday this engine will run right.

Quote:
Originally Posted by oldskool View Post
i heard you can't run solid core ign wires with pertronix is that correct?



Thats correct the Pertronix will not run correctly with solid core ignition wires especially if its a 6 volt system. Things get really bad when its a six volt system I know from first hand experience. Another issue with 6 volts any ignition resister should be removed for the conversion. Theres no longer any need to reduce the voltage to the ignition system when converting to Pertronix this apply's to 6 volt as well as 12 volt. And the final no no is do not leave the ignition switch on if the engine is not running that will kill the module how long it takes however is a mystery.
Ronnieroadster
__________________
I use the F word a lot no not that word these words Flathead , Focus and Finish.
"Life Member of the Bonneville 200 MPH Club using a Ford Flathead block"
Owner , Builder and Driver of the First Ford Flathead bodied roadster to run 200 MPH Record run July 13, 2018 LTA timing association 200.921 from a standing start in one and a half miles burning gasoline.
Ronnieroadster is offline   Reply With Quote
Old 07-16-2020, 05:24 PM   #13
Fritz
Member
 
Fritz's Avatar
 
Join Date: May 2010
Location: Northern IL
Posts: 41
Default Re: Someday this engine will run right.

I have a 6 volt system and a pertronix on a crab distributor. Zero problems and it runs.I feel your pain with the original style replacement points, coils, etc. I went with the pertronix several years ago and have never looked back. I have the original style replacement cloth wrapped spark plugs and use the coil that Pertonix recommends.

How long did you leave the switch on? You can always call Pertronix support. I initially thought I had coil issues and they were very helpful.
__________________
Cars and metal rust and are destroyed, but the Word of God will never pass away (Matt. 24:35).
Fritz is offline   Reply With Quote
Old 07-16-2020, 06:17 PM   #14
dgmgohl
Member
 
Join Date: Aug 2018
Posts: 42
Default Re: Someday this engine will run right.

Hi Fritz, I do have the Pertronix coil that is recommended. I remember that I did leave the switch on when doing the timing. Forgot to turn it off. What is bewildering is that the engine stopped while running. Not sure if that is normal or not. I did call Pertronix, they were very helpful. Since I did buy the unit from Amazon, I've already been cleared to send it back defective. No questions asked.
dgmgohl is offline   Reply With Quote
Old 07-16-2020, 06:19 PM   #15
dgmgohl
Member
 
Join Date: Aug 2018
Posts: 42
Default Re: Someday this engine will run right.

Thanks, I'm sure that's what happened to my Pertronix unit. I've ordered another, this time to be more careful.
dgmgohl is offline   Reply With Quote
Old 07-16-2020, 06:22 PM   #16
dgmgohl
Member
 
Join Date: Aug 2018
Posts: 42
Default Re: Someday this engine will run right.

Tubman, thanks for the clarification. I've learned a lot from members like you on different subjects. I keep reading and learning. Thanks for teaching me something new.
dgmgohl is offline   Reply With Quote
Old 07-20-2020, 06:32 PM   #17
scicala
Senior Member
 
scicala's Avatar
 
Join Date: Jun 2010
Location: Detroit suburb, MI
Posts: 2,986
Default Re: Someday this engine will run right.

"I run a teapot carb recently rebuilt by scalia here on ford barn."


Just a slight correction in case I can help somebody with a carb issue.
My ID is scicala

Sal
scicala is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 08:06 PM.