Go Back   The Ford Barn > Search Forums

Sponsored Links (Register now to hide all advertisements)

Showing results 1 to 7 of 7
Search took 0.00 seconds.
Search: Posts Made By: eolson
Forum: Model A (1928-31) 03-30-2020, 08:24 AM
Replies: 13
Views: 743
Posted By eolson
Re: How to get chrome spare tire cover onto the tire

Thanks Everyone for your input, it's been very helpful.

old31: Tires are BF Goodrich 475/500-19 from Coker. The chrome covers were on the car when I purchased it, so I'm not sure where they came...
Forum: Model A (1928-31) 03-21-2020, 09:57 AM
Replies: 13
Views: 743
Posted By eolson
Re: How to get chrome spare tire cover onto the tire

Thanks, Mike. Twisting it has been my main strategy so far, but haven’t been able to get it to go. Should have lifted more weights in HS.
Forum: Model A (1928-31) 03-21-2020, 09:51 AM
Replies: 13
Views: 743
Posted By eolson
Re: How to get chrome spare tire cover onto the tire

Funny you say that, Ruth, because right after I posted, I wanted to check something with the mirror that sits on the tire and discovered that the chain no longer reached around. The new replacement...
Forum: Model A (1928-31) 03-20-2020, 09:02 PM
Replies: 13
Views: 743
Posted By eolson
Question How to get chrome spare tire cover onto the tire

I have a 1930 deluxe roadster with the spare tires in the front fenders. They have chrome/polished covers. Does anyone have any tips about how to get these things back on to the spare? Iíve been...
Forum: Model A (1928-31) 02-10-2020, 02:50 PM
Replies: 196
Views: 28,484
Posted By eolson
Re: Model A car names

Charlotte

1930 Deluxe Roadster. A southern girl with some North Carolina history.
Forum: Model A (1928-31) 11-03-2019, 09:05 AM
Replies: 20
Views: 6,740
Posted By eolson
Re: signal stat 900 question

I know this is an older post, but I found it because I had the same problem mentioned in the OP. I was skeptical that it could be as simple as a junk flasher, but I ordered a new one, and sure...
Forum: Model A (1928-31) 10-21-2019, 09:42 AM
Replies: 2
Views: 480
Posted By eolson
Question Problem with a SignalStat turn signal switch

Greetings Everyone,

I have a turn signal question. I recently replaced what looked like a very old installation of a SignalStat turn signal kit in my 6v 1930 Model A Roadster (signals werenít...
Showing results 1 to 7 of 7

 
Forum Jump
Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 07:25 PM.