Go Back   The Ford Barn > Search Forums

Sponsored Links (Register now to hide all advertisements)

Showing results 1 to 7 of 7
Search took 0.00 seconds.
Search: Posts Made By: Nomadtrebor
Forum: Model A (1928-31) 12-20-2020, 06:15 PM
Replies: 8
Views: 848
Posted By Nomadtrebor
Re: Clutch Problem

OK, I have clutch pedal spring now. I found that the Pressure plate fingers were not adjusted to spec. But, even with that i still do not have a Properly working clutch. My new question is: should...
Forum: Model A (1928-31) 12-19-2020, 07:45 AM
Replies: 8
Views: 848
Posted By Nomadtrebor
Clutch Problem

I recently acquired a 1928 Model A pick up. 90% very nicely restored.
Discovered a problem with the clutch - It doesn't seem to have much if any spring to it. neither way, up or down. does anyone...
Forum: Early V8 (1932-53) 01-16-2020, 02:58 PM
Replies: 23
Views: 2,812
Posted By Nomadtrebor
Re: Card from my sister

Are we still talking about cars ? LOL
Forum: Early V8 (1932-53) 01-16-2020, 02:58 PM
Replies: 23
Views: 2,812
Posted By Nomadtrebor
Re: Card from my sister

With age comes a greater appreciation
Forum: Model A (1928-31) 01-16-2020, 12:30 PM
Replies: 12
Views: 825
Posted By Nomadtrebor
Re: Brake light problem

The brake lights do not come on at all
Forum: Model A (1928-31) 01-16-2020, 10:57 AM
Replies: 12
Views: 825
Posted By Nomadtrebor
Re: Brake light problem

6 volt positive ground
Forum: Model A (1928-31) 01-16-2020, 10:45 AM
Replies: 12
Views: 825
Posted By Nomadtrebor
Brake light problem

I recently bought my first model A, (1930 Phaeton)
I'm having a problem with my brake light
all lights seem to work properly with the steering wheel lever switch, but when i step on the brakes the...
Showing results 1 to 7 of 7

 
Forum Jump
Sponsored Links (Register now to hide all advertisements)


All times are GMT -5. The time now is 10:23 AM.