The Ford Barn

The Ford Barn (https://www.fordbarn.com/forum/index.php)
-   Model A (1928-31) (https://www.fordbarn.com/forum/forumdisplay.php?f=3)
-   -   Carb, Tillotson, Air Balanced (https://www.fordbarn.com/forum/showthread.php?t=298707)

LAV 05-17-2021 06:49 PM

Carb, Tillotson, Air Balanced
 

Anyone have a problem getting a new Carb, Tillotson, Air Balanced to run? I had to make a lot of adjustments to the float level to get to run when I first got it. I bent the float and used shims. After a few days of running well it stop and I have had problems since. My fuel is clean. Ive had to set the float level to 1.3 to stop leaking. I can get it to run periodically but when it does it rough. Nothing I do adjusting makes much difference. Could use some suggestions, Thanks.

nkaminar 05-17-2021 06:57 PM

Re: Carb, Tillotson, Air Balanced
 

Did you fill up the gas tank? Perhaps additional pressure is causing a marginal float valve to leak. If you have to set the level that high then there is a problem with the float valve. Look at the exhaust to see if it is black with carbon or look at the plugs for the same reason. You may have to send the new Tillotson back for repair under the warranty. Try turning off the fuel to see if it runs better as the level in the carburetor goes down. You should not have to mess with the float level to make it run right. Send it back.

I bought a used Tillotson that had been rebuilt and have had no problems with it.

One other thought: If you are using an air filter, take it off to see if that makes a difference.

Anteek29 05-17-2021 08:08 PM

Re: Carb, Tillotson, Air Balanced
 

Problem is with the float valve.

Herb Concord Ca 05-17-2021 09:45 PM

Re: Carb, Tillotson, Air Balanced
 

Try using a Viton tipped float valve.


All times are GMT -5. The time now is 01:40 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.